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Introduction 

BiesseWorks is the machining software for programming Biesse numerically controlled machines. 
The interface sends the parts drawn in TopSolid'Wood to BiesseWorks with the machining definitions. 
TopSolid'Wood then produces a .cix file which can be directly opened in BiesseWorks. 
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TopSolid'Wood configuration 
 

Export to BiesseWorks can be configured in Tools > Options > TopSolid'Wood 
configuration > Machining > Biesse CIX configuration. 
 

General configuration 

- Number of decimals: Corresponds to the number of decimal places to be exported. Let's take a drilling 
10.1234mm deep, for example, for 3 decimal places, the depth exported to BiesseWorks will be 10.123mm. 

 

- Tolerance of discretization: The tolerance of discretization defines the level of accuracy used to export the 
machining geometries, including curved and circular paths. The finer the tolerance, the closer the exported 
curve is to the drawn curve, but the longer the calculation. The value of 1e-05 (in meters) is the most common 
average value used, because it provides a good compromise between precision and performance. 

 

- Files save path: Lets you specify the path of the directory where the exported files will be saved. 

 

Note: By default, if no directory is specified, the files will be saved in the folder of the exported project. 

- The Unit section lets you configure the type of unit (Millimeter or Inch) for the machining file. 
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Configuring default machining options 

You can adjust some default machining settings in the TopSolid'Wood configuration. 

Drilling settings 

- Maximum diameter: This option lets you specify a maximum drilling diameter for machining. 
If the drilling diameter is strictly greater than this setting value (in millimeters), the drilling is not exported 
to BiesseWorks. 

 

Tool path setting for grooves, rabbets and mouldings 

You can choose to export the centered or shifted tool path for each operation (Groove, Rabbet and Moulding). 

Tool path settings can be configured in Tools > Options > TopSolid'Wood configuration > Machining > Biesse CIX 
configuration. 

 

Examples of groove exports with the Centered option (left) and Shifted option (right) enabled: 

   

Note: This setting will be only applied to grooves and rabbets using a router. 
The grooves that go through the part are systematically exported in Centered mode. 
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Tool calibration over-thickness value 

You are able to export an over-thickness value for calibration machining to BiesseWorks. This value corresponds to 
the tool's exceeding value under the part. 

This default value can be adjusted in Tools > Options > TopSolid'Wood configuration > Machining > Over-thickness 
(-Z). 

 

Note: This default value can be modified at each export in the part selection window. 

 

BOM configuration for part selection sorting 

You can set a default BOM file for part selection sorting in TopSolid'Wood. 

The BOM file to be used for part sorting can be set in Tools > Options > TopSolid'Wood 
configuration > Files > Part selection sorting. 

 

 

BiesseWorks executable location configuration 

In order to automatically launch BiesseWorks after a machining export from TopSolid'Wood, you can specify the 
location of the BiesseWorks executable. 

The executable path can be set in Tools > Options > 
TopSolid'Wood configuration > Files > Applications. 
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Export configuration using configuration keywords 

The configuration keywords are used to set some export parameters that are less common than those available in 
Tools > Options > TopSolid'Wood configuration. 

To modify/add configuration keywords, proceed as follows: 

 Using the Notepad (or any other text editor), open the topzwoo.cfg file which is located in the folder 
Missler/ConfigV6x/V6x/topzwoo.cfg. 

Note: When in a Group configuration, open the Missler/GroupV6x/V6x/topzwoo.cfg file. 
In this file, copy and paste the configuration keywords followed by the rules (setting values) separated by a tab 
character. 

 Before pasting a new configuration keyword, check that it does not already exist by using the Search function 
of the Notepad (Edit > Search or Ctrl + F). 

 

General configuration keywords 

Configuration keyword Value Result 

ZX_ZWOO_CAM_NO_CALIBRATION 1 Automatically deactivates the 
part's calibration when the 
overdimension values are set to 
Edge shape or Abacus mode. 

0 (default value) The part's calibration is always 
exported. 

ZX_ZWOO_CAM_CALIBRATION_CHANGE_ORIGIN 1 The starting point of the part's 
calibration will be in the middle 
of a calibration segment. 

0 (default value) The starting point of the part's 
calibration will be at the end of a 
calibration segment. 

ZX_ZWOO_CAM_GROUP_DRILLS 1 (default value) Groups together the drillings 
during export. 

0 Allows the drillings not to be 
grouped together during export. 

D_SH_OP_POC_USE_MAC_PROPERTY 1 Allows for the correct export of 
overlapping operations with 
pockets. 

0 (default value)  
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ZX_ZWOO_CAM_REMOVE_FACING_HOLE 1 Allows the through hole of a spot 
facing not to be exported. 

0 The spot facing and the through 
hole are exported. 

ZX_ZWOO_CAM_THROUGH_DRILL_IN_FIRST_FILE 0 (default value) Through holes are exported on 
their reference face. 

1 In Two files if necessary mode, 
the through holes are exported in 
the first machining file. 

ZX_ZWOO_CAM_THROUGH_DRILL_ABOVE_ONE_FI
LE 

1 (default value) In One machining file mode, the 
bottom through holes are 
exported on the top face. 

0 Through holes are exported on 
their reference face. 

ZX_ZWOO_CAM_THROUGH_POC_ABOVE 1 (default value) Exports the bottom through 
pockets on the top face. 

0 Through pockets are exported on 
their reference face. 

ZX_ZWOO_CAM_MPR_THROUGH_POC_TO_MILL 1 (default value) Through pockets are exported as 
millings. Only the contour of the 
pocket will be exported. 

0 A through pocket is exported as a 
pocket. All of the material will be 
machined. 

ZX_ZWOO_CAM_MPR_INSIDE_SAWING_TO_MILL 1 Exports the closed trimmings 
performed inside the part as a 
milling. 

0 The closed trimmings performed 
inside a part are not exported. 

ZX_ZWOO_CAM_MPR_MILL_CHANGE_ORIGIN 1 The starting point of the part's 
internal milling will be in the 
middle of a milling segment. 

0 (default value) The starting point of the part's 
internal milling will be at the end 
of a milling segment. 

ZX_ZWOO_CAM_DRILL_DEPTH_WITHOUT_TIP 0 (default value) The drilling depth is exported 
without the tip. 

1 The drilling depth is exported with 
the tip. 

ZX_ZWOO_CAM_THROUGH_DRILL_IN_FIRST_FILE 0 (default value) Through holes are exported on 
their reference face. 

1 In Two files if necessary mode, 
the through holes are exported in 
the first machining file. 
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Interface-specific configuration keywords 

 

Configuration keyword Value Result 

ZX_ZWOO_CAM_CIX_DRILL_TOOL_NAME 101 
 
""(default value) 

Default tool number assigned 
to the drilling operation. 

ZX_ZWOO_CAM_CIX_POCKET_TOOL_NAME 101 
 
""(default value) 

Default tool number assigned 
to the pocket operation. 

ZX_ZWOO_CAM_CIX_MILL_TOOL_NAME 101 
 
""(default value) 

Default tool number assigned 
to the milling/calibration with 
router 

ZX_ZWOO_CAM_CIX_SLOT_MILL_TOOL_NAME 101 
 
""(default value) 

Default tool number assigned 
to the groove with router. 

ZX_ZWOO_CAM_CIX_SLOT_SAW_TOOL_NAME 101 
 
""(default value) 

Default tool number assigned 
to the groove with saw. 

ZX_ZWOO_CAM_CIX_THROUGH_POC_DEPTH_OFFSET 0.003 
 

""(default value). 

Default over-thickness 
dimensions (in meters) used 
for through pockets. 
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BiesseWorks configuration 

No special settings are required in BiesseWorks to import the files generated by TopSolid'Wood. 
However, some options such as tool compensation reversal can be adjusted via File > Settings. 

 From the Password tab, enter the password (proman by default) and click the Confirm button to validate. 

 

 From the Machining operations tab, check or uncheck the User correction option. 

 

 Confirm the options using the Save and exit button.  
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Making an export 

From TopSolid'Wood 

 Select Wood > Machining export > Export to Biesse CIX. 

  
 
Note: The Machining export > Export to Biesse CIX function can also be accessed from the icon bar of the Wood 
context (on the left side of the screen). 

 Choose the One part or Multi-parts mode.  

- The One part mode lets you export only one part. You can also use this mode to add milling operations to 
the part manually. 

- The Multi-parts mode lets you export several parts of an assembly. 

One part mode 

 Select the One part mode.  

The file explorer opens in the folder that is defined by default in Tools > Options. 

 Select the folder where you want your file saved and give the exported file a name (by default the name of the 
original Design file). 

 Select the part to be exported to BiesseWorks. 

 

 If the selected part is set to Optimized machining mode, the following two options are available: 

- OK to continue without updating the machining face. 
- Update machining face to update the machining face of the exported part.  
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 Next pick the positioning face (CNC positioning face, the bottom in BiesseWorks). 

 Select the Positioning for part definition option to use the positioning face set in the part definition.  

 

 

Note: The part is placed in top view in relation to the selected face. 

 Select the part's positioning orientation for the BiesseWorks machining export using the << and >> arrows from 
the dialog bar. 

 Click OK to confirm the positioning. 
 

 
 

                  Part displayed in TopSolid'Wood                    Part positioning in BiesseWorks 

Note: In TopSolid'Wood, the part's horizontal axis from left to right will be the X+ axis in BiesseWorks and the 
vertical axis from bottom to top will be Y+. 

 The Other routings of contour button lets you add milling operations to the exported part: 

 

- Edges on planar face: Lets you select several edges at once from a reference selected face. 

  

- All face edges: Selects all edges of the selected face.  

- Relative depth: Machining depth value (in millimeters).  
- Depth from face: The relative depth value is calculated by default from the reference face you selected 

previously. To change the reference face for the machining depth, click Depth from face and select the new 

reference face for the machining depth.  
- Follow tangent edges = Yes/No: You can choose to associate or not associate the tangent edges with the 

selected edge.  
- Reference edge for tool path: Lets you pick the edges you want to add to the tool path. 
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 Once you have selected one or more edges, click OK to confirm. 

 It is possible to select another reference face. If you want to keep the previously selected face, click Stop.  

Note: All paths selected from the Other routings of contour option, except those selected from Edges on planar 
face, are not aggregated as a single machining. Each selected edge will be exported as one separate machining. 

 Click OK to confirm the other routings in order to create the CIX file. 

Multi-parts mode 

 Select the Multi-parts mode.  

Several options for selecting parts are available in the dialog bar: 

- Main assembly: Selects all parts of the main assembly.  

 

- If several sub-assemblies are created in the document, a drop-down list appears and lets you select a sub-

assembly  
- Depth: Lets you select the depth type to display the elements of the selected assembly. 

 

- Filter bom by criteria: Lets you select a filter to filter the parts in the selected assembly.  

 

- Update machining face: This option is available if one part is in Optimized machining mode. It updates the 
machining faces of parts exported in Optimized mode. 

 

- Select element to use: Lets you select parts manually: 
o Left-click on the parts to be selected. Once the parts are selected, they turn red. 

o Click STOP to confirm the selected part(s).  
 
The Multi machinings window opens. 

- Over-thickness: The default over-thickness value is 
provided in Tools > Options, but you can modify this value 
for the exported project. 

- Select type: Part selection mode. 
- Expand all/Back-up: Opens or closes all of the assembly in 

the BOM. 
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 Right-clicking on a part of the list displays several options: 

- Select: Selects the part. 
- Deselect: Deselects the part. 
- Select same parts: Selects all parts that are identical to the selected ones. 
- Positioning: Opens the setting window for the part positioning. This window 

allows you to change the positioning direction of the part in BiesseWorks. 
 
Note: This change in positioning will only apply to this export. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Note: At the bottom of the window, an information box indicates the number of selected parts. 

 

 Selecting the Close files option prevents the generated files from opening. Check this box when exporting a lot 
of parts. 

 
 

 Click OK to start the export. 

 The folder selection window opens on the folder configured in the 
options. Select a destination folder for the exported files.  

 
 
 
 
 
 
 
 
 
 
TopSolid'Wood then generates the CIX files. Once the export is finished, the number of generated files is displayed 
in the alpha bar. 

 

Note: If you did not check the Close files option, all the generated files will be opened. 
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From BiesseWorks 

 If the part does not open automatically, click File > Open and select the generated .cix file. 

By default, the screen is divided into the following three areas: 

 
 

1. Program 

This area lists all the operations performed on the part and allows you to edit them with double-click or 
show/hide them in the graphics area using checkboxes.  

 
 

2. Graphic display area 

This area displays the 2D part. The different 2D views of the part's faces can be displayed using the lower bar 
of the area. 

 

The part's operations can also be edited from the area. 
 
 

3. Edit field 

This area displays the program lines for each operation of the part. Values like coordinates can be changed from 
this area.  
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